Some emails not being delivered
Incident Report for TrackJS
Resolved
Our email provider has given the all-clear that things should be resolved and back to normal.
Posted 11 months ago. May 17, 2018 - 14:03 CDT
Monitoring
Our third party email provider is having API instability this morning. Some emails are not being delivered. We are monitoring the situation and will update soon.
Posted 11 months ago. May 17, 2018 - 10:16 CDT