Partial Email Outage
Incident Report for TrackJS
Resolved
This incident has been resolved.
Posted 11 months ago. May 24, 2018 - 15:23 CDT
Investigating
There is an outage with our email provider preventing some emails from being delivered. We are working with the provider to identify and resolve the issue.
Posted 11 months ago. May 24, 2018 - 13:23 CDT
This incident affected: Management UI.